What’s Vulnerable › Vulnerabilities
CVE-2024-13616: VikBooking < 1.7.2 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The VikBooking Hotel Booking Engine & PMS WordPress plugin before 1.7.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- e4jvikwp VikBooking Hotel Booking Engine & PMS: before 1.7.2 — fixed in 1.7.2
How to fix
Upgrade to a fixed version: e4jvikwp VikBooking Hotel Booking Engine & PMS 1.7.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/44b3a2d9-a2e1-43dd-b27a-1ad9d6015c9b/
- https://wpscan.com/vulnerability/44b3a2d9-a2e1-43dd-b27a-1ad9d6015c9b/
Get alerted when CVE-2024-13616 or the next vulnerability affects your stack