What’s Vulnerable › Vulnerabilities
CVE-2024-1362: Colibri Page Builder <= 1.0.253 - Cross-Site Request Fogery via cp_shortcode_refresh
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-23 · updated 2026-06-17
- Weakness: CWE-352
Description
The Colibri Page Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.253. This is due to missing or incorrect nonce validation on the cp_shortcode_refresh() function. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- extendthemes Colibri Page Builder: before 1.0.260 — fixed in 1.0.260
How to fix
Upgrade to a fixed version: extendthemes Colibri Page Builder 1.0.260. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3039597/colibri-page-builder/trunk/src/PageBuilder.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a5e7a994-c489-4aea-a9bb-898bc92cae4e?source=cve
- https://plugins.trac.wordpress.org/changeset/3039597/colibri-page-builder/trunk/src/PageBuilder.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a5e7a994-c489-4aea-a9bb-898bc92cae4e?source=cve
Get alerted when CVE-2024-1362 or the next vulnerability affects your stack