What’s Vulnerable › Vulnerabilities
CVE-2024-13642: Stratum – Elementor Widgets <= 1.4.7 - Authenticated (Contributor+) Stored Cross-Site Scripting Vulnerability via Image Hotspot Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Stratum – Elementor Widgets plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Image Hotspot widget in all versions up to, and including, 1.4.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- jetmonsters Stratum Widgets for Elementor: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: jetmonsters Stratum Widgets for Elementor 1.5.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3228058#file6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7ccaee26-277e-4730-8242-9b5e6a281fcc?source=cve
Get alerted when CVE-2024-13642 or the next vulnerability affects your stack