What’s Vulnerable › Vulnerabilities
CVE-2024-13658: NGG Smart Image Search <= 3.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The NGG Smart Image Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'hr_SIS_nextgen_searchbox' shortcode in all versions up to, and including, 3.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpo-HR NGG Smart Image Search: before 3.3.2 — fixed in 3.3.2
How to fix
Upgrade to a fixed version: wpo-HR NGG Smart Image Search 3.3.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3233519%40ngg-smart-image-search&new=3233519%40ngg-smart-image-search&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d916e320-e78b-4305-a4da-10c6fb8db41a?source=cve
Get alerted when CVE-2024-13658 or the next vulnerability affects your stack