What’s Vulnerable › Vulnerabilities
CVE-2024-13661: Table Editor <= 1.5.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Table Editor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wptableeditor_vtabs' shortcode in all versions up to, and including, 1.5.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wptableeditor Table Editor: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: wptableeditor Table Editor 1.6.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-table-editor/trunk/includes/public/shortcode.php#L333
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3228279%40wp-table-editor&new=3228279%40wp-table-editor&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3fe1f3c3-4a81-4aae-9a5e-e5889f4c69ba?source=cve
Get alerted when CVE-2024-13661 or the next vulnerability affects your stack