What’s Vulnerable › Vulnerabilities
CVE-2024-13664: WP Post List Table <= 1.0.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Post List Table plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wpb_post_list_table' shortcode in all versions up to, and including, 1.0.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpbean WP Post List Table: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: wpbean WP Post List Table 1.0.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3227735/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b18f6817-86db-4a72-a2e9-a9e047e05bc5?source=cve
Get alerted when CVE-2024-13664 or the next vulnerability affects your stack