What’s Vulnerable › Vulnerabilities
CVE-2024-13672: Mini Course Generator | Embed mini-courses and interactive content <= 1.0.5 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Mini Course Generator | Embed mini-courses and interactive content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'mcg' shortcode in all versions up to, and including, 1.0.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- minicoursegenerator Mini Course Generator | Embed mini-courses and interactive content: before 1.0.6 — fixed in 1.0.6
How to fix
Upgrade to a fixed version: minicoursegenerator Mini Course Generator | Embed mini-courses and interactive content 1.0.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/mini-course-generator/tags/1.0.4/includes/class-mcg-shortcodes.php#L10
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3243023%40mini-course-generator&new=3243023%40mini-course-generator&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b47505a5-fb7f-4e41-a6de-6f0b330aa495?source=cve
Get alerted when CVE-2024-13672 or the next vulnerability affects your stack