What’s Vulnerable › Vulnerabilities
CVE-2024-13675: SlingBlocks – Gutenberg Blocks by FunnelKit (Formerly WooFunnels) <= 1.5.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The SlingBlocks – Gutenberg Blocks by FunnelKit (Formerly WooFunnels) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the "Icon List" Block in all versions up to, and including, 1.5.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- amans2k SlingBlocks – Gutenberg Blocks by FunnelKit (Formerly WooFunnels): before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: amans2k SlingBlocks – Gutenberg Blocks by FunnelKit (Formerly WooFunnels) 1.6.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3251693%40slingblocks&new=3251693%40slingblocks&sfp_email=&sfph_mail=#file5
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f34904b5-3b3d-46d3-9e33-ef661d5f4149?source=cve
Get alerted when CVE-2024-13675 or the next vulnerability affects your stack