What’s Vulnerable › Vulnerabilities
CVE-2024-13681: Uncode <= 2.9.1.6 - Unauthenticated Arbitrary File Read in uncode_admin_get_oembed
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-20
Description
The Uncode theme for WordPress is vulnerable to arbitrary file read due to insufficient input validation in the 'uncode_admin_get_oembed' function in all versions up to, and including, 2.9.1.6. This makes it possible for unauthenticated attackers to read arbitrary files on the server.
Affected products
- undsgn Uncode: before 2.9.1.7 — fixed in 2.9.1.7
How to fix
Upgrade to a fixed version: undsgn Uncode 2.9.1.7. Check the vendor advisory for mitigations.
References
- https://support.undsgn.com/hc/en-us/articles/213454129-Change-Log
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7914ebe6-b5e1-4a1a-8794-80f515e6c9f6?source=cve
Get alerted when CVE-2024-13681 or the next vulnerability affects your stack