What’s Vulnerable › Vulnerabilities
CVE-2024-13691: Uncode <= 2.9.1.6 - Authenticated (Subscriber+) Arbitrary File Read in uncode_recordMedia
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-20
Description
The Uncode theme for WordPress is vulnerable to arbitrary file read due to insufficient input validation in the 'uncode_recordMedia' function in all versions up to, and including, 2.9.1.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read arbitrary files on the server.
Affected products
- undsgn Uncode: before 2.9.1.7 — fixed in 2.9.1.7
How to fix
Upgrade to a fixed version: undsgn Uncode 2.9.1.7. Check the vendor advisory for mitigations.
References
- https://support.undsgn.com/hc/en-us/articles/213454129-Change-Log
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d592141d-191b-4739-bc0a-07549ef2f31b?source=cve
Get alerted when CVE-2024-13691 or the next vulnerability affects your stack