What’s Vulnerable › Vulnerabilities
CVE-2024-13694: WooCommerce Wishlist <= 1.8.7 - Unauthenticated Wishlist Disclosure via download_pdf_file Function
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-285
Description
The WooCommerce Wishlist (High customization, fast setup,Free Elementor Wishlist, most features) plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.8.7 via the download_pdf_file() function due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to extract data from wishlists that they should not have access to.
Affected products
- Moreconvert Team MC Woocommerce Wishlist: before 1.8.8 — fixed in 1.8.8
How to fix
Upgrade to a fixed version: Moreconvert Team MC Woocommerce Wishlist 1.8.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/smart-wishlist-for-more-convert/trunk/includes/class-wlfmc-form-handler.php#L607
- https://plugins.trac.wordpress.org/browser/smart-wishlist-for-more-convert/trunk/includes/class-wlfmc-wishlist.php#L529
- https://plugins.trac.wordpress.org/changeset/3229758/
- https://wordpress.org/plugins/smart-wishlist-for-more-convert/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/59fe7630-ab94-419f-aca5-39b74d86ae4e?source=cve
Get alerted when CVE-2024-13694 or the next vulnerability affects your stack