What’s Vulnerable › Vulnerabilities
CVE-2024-13699: Qi Addons For Elementor <= 1.8.7 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Qi Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘cursor’ parameter in all versions up to, and including, 1.8.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in versions 1.8.5, 1.8.6, and 1.8.7.
Affected products
- qodeinteractive Qi Addons For Elementor: through 1.8.7
References
- https://plugins.trac.wordpress.org/browser/qi-addons-for-elementor/trunk/inc/shortcodes/typeout-text/class-qiaddonsforelementor-typeout-text-shortcode.php
- https://plugins.trac.wordpress.org/changeset/3230342/
- https://plugins.trac.wordpress.org/changeset/3231980/
- https://plugins.trac.wordpress.org/changeset/3232550/
- https://plugins.trac.wordpress.org/changeset/3234136/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/add39d28-4070-44e2-8dff-0371e0c58453?source=cve
Get alerted when CVE-2024-13699 or the next vulnerability affects your stack