What’s Vulnerable › Vulnerabilities
CVE-2024-13704: Super Testimonials <= 4.0.1 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-80
Description
The Super Testimonials plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'st_user_title' parameter in all versions up to, and including, 4.0.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- themepoints Super Testimonial – Testimonial & Customer Review Slider Plugin for WordPress: before 4.0.2 — fixed in 4.0.2
How to fix
Upgrade to a fixed version: themepoints Super Testimonial – Testimonial & Customer Review Slider Plugin for WordPress 4.0.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3240039%40super-testimonial&new=3240039%40super-testimonial&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/20720912-6bfd-4df1-97c7-7025c16d7a0f?source=cve
Get alerted when CVE-2024-13704 or the next vulnerability affects your stack