What’s Vulnerable › Vulnerabilities
CVE-2024-13716: Forex Calculators <= 1.3.7 - Missing Authorization to Authenticated (Subscriber+) Settings Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-862
Description
The Forex Calculators plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the ajax_settings_callback() function in all versions up to, and including, 1.3.7. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the plugin's settings.
Affected products
- tarborali Forex Calculators: before 1.3.8 — fixed in 1.3.8
How to fix
Upgrade to a fixed version: tarborali Forex Calculators 1.3.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/fx-calculators/tags/1.3.5/forex-calculators.php#L101
- https://plugins.trac.wordpress.org/changeset/3247313/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/49ce8ca1-c1ae-4dda-909e-70c3b6d2b561?source=cve
Get alerted when CVE-2024-13716 or the next vulnerability affects your stack