What’s Vulnerable › Vulnerabilities
CVE-2024-13718: Flexible Wishlist for WooCommerce – Ecommerce Wishlist & Save for later <= 1.2.26 - Cross-Site Request Forgery to Wishlist Creation/Modification
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-352
Description
The Flexible Wishlist for WooCommerce – Ecommerce Wishlist & Save for later plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.2.26. This is due to missing or incorrect nonce validation on several functions. This makes it possible for unauthenticated attackers to modify/update/create other user's wishlists via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- wpdesk Flexible Wishlist for WooCommerce – Ecommerce Wishlist & Save for later: before 1.2.27 — fixed in 1.2.27
How to fix
Upgrade to a fixed version: wpdesk Flexible Wishlist for WooCommerce – Ecommerce Wishlist & Save for later 1.2.27. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?old_path=flexible-wishlist/tags/1.2.26&new_path=/flexible-wishlist/tags/1.2.27&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1f2b4030-92b1-4795-b72e-761632dd523d?source=cve
Get alerted when CVE-2024-13718 or the next vulnerability affects your stack