What’s Vulnerable › Vulnerabilities
CVE-2024-13723: Checkmk NagVis Remote Code Execution
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-434
Description
The "NagVis" component within Checkmk is vulnerable to remote code execution. An authenticated attacker with administrative level privileges is able to upload a malicious PHP file and modify specific settings to execute the contents of the file as PHP.
Affected products
- Checkmk NagVis: from NagVis 1.9.40 before 1.9.42; from Checkmk 2.3.0p2 before 2.3.0p10 — fixed in 1.9.42, 2.3.0p10
How to fix
Upgrade to a fixed version: Checkmk NagVis 1.9.42, 2.3.0p10. Check the vendor advisory for mitigations.
References
- https://checkmk.com/werks?version=2.3.0p10
- https://korelogic.com/Resources/Advisories/KL-001-2025-002.txt
- https://www.nagvis.org/downloads/changelog/1.9.42
- http://seclists.org/fulldisclosure/2025/Feb/4
- http://www.openwall.com/lists/oss-security/2025/02/04/4
- https://lists.debian.org/debian-lts-announce/2025/05/msg00000.html
- https://korelogic.com/Resources/Advisories/KL-001-2025-002.txt
Get alerted when CVE-2024-13723 or the next vulnerability affects your stack