What’s Vulnerable › Vulnerabilities
CVE-2024-13727: MemberSpace – Membership Plugin and Paid Subscriptions < 2.1.14 - Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The MemberSpace WordPress plugin before 2.1.14 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against only unauthenticated users.
Affected products
- MemberSpace: before 2.1.14 — fixed in 2.1.14
How to fix
Upgrade to a fixed version: MemberSpace 2.1.14. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/598d20f2-0f42-48f2-a941-0d6c5da5303e/
- https://wpscan.com/vulnerability/598d20f2-0f42-48f2-a941-0d6c5da5303e/
Get alerted when CVE-2024-13727 or the next vulnerability affects your stack