What’s Vulnerable › Vulnerabilities
CVE-2024-13732: Responsive Blocks – WordPress Gutenberg Blocks <= 1.9.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via section_tag Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive Blocks – WordPress Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘section_tag’ parameter in all versions up to, and including, 1.9.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- CyberChimps Responsive Blocks: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: CyberChimps Responsive Blocks 2.0.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/responsive-block-editor-addons/trunk/src/blocks/post-carousel/index.php#L643
- https://plugins.trac.wordpress.org/changeset/3231017/
- https://wordpress.org/plugins/responsive-block-editor-addons
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1c0e5c85-72c3-4f09-aade-ec5a82b9cc41?source=cve
Get alerted when CVE-2024-13732 or the next vulnerability affects your stack