What’s Vulnerable › Vulnerabilities
CVE-2024-13733: SKT Blocks – Gutenberg based Page Builder <= 1.7 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The SKT Blocks – Gutenberg based Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's skt-blocks/post-carousel block in all versions up to, and including, 1.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2025-26771 is a duplicate of this issue.
Affected products
- sonalsinha21 SKT Blocks: before 1.8 — fixed in 1.8
How to fix
Upgrade to a fixed version: sonalsinha21 SKT Blocks 1.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/skt-blocks/trunk/src/blocks/post-carousel/index.php#L751
- https://plugins.trac.wordpress.org/changeset/3233980/
- https://wordpress.org/plugins/skt-blocks
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a5a84999-bd1b-4b86-9fa1-09c20b50ce37?source=cve
Get alerted when CVE-2024-13733 or the next vulnerability affects your stack