What’s Vulnerable › Vulnerabilities
CVE-2024-13734: Card Elements for Elementor <= 1.2.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via Profile Card Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Card Elements for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Profile Card widget in all versions up to, and including, 1.2.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- techeshta Card Elements for Elementor: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: techeshta Card Elements for Elementor 1.2.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3244795/
- https://wordpress.org/plugins/card-elements-for-elementor/#developers
- https://www.techeshta.com/docs/card-elements-for-elementor/element-settings/profile-card/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7134bb24-11a1-41f9-ad34-b4527c22463c?source=cve
Get alerted when CVE-2024-13734 or the next vulnerability affects your stack