What’s Vulnerable › Vulnerabilities
CVE-2024-13735: HurryTimer <= 2.11.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Campaign Name
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The HurryTimer – An Scarcity and Urgency Countdown Timer for WordPress & WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.11.2 due to insufficient input sanitization and output escaping of a campaign name. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- nlemsieh HurryTimer – An Scarcity and Urgency Countdown Timer for WordPress & WooCommerce: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: nlemsieh HurryTimer – An Scarcity and Urgency Countdown Timer for WordPress & WooCommerce 2.12.0. Check the vendor advisory for mitigations.
References
- https://docs.hurrytimer.com/getting-started/creating-a-one-time-campaign
- https://plugins.trac.wordpress.org/changeset/3239755/
- https://wordpress.org/plugins/hurrytimer/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a5b247a7-50f4-4d35-b24a-2c788ba0b051?source=cve
Get alerted when CVE-2024-13735 or the next vulnerability affects your stack