What’s Vulnerable › Vulnerabilities
CVE-2024-13748: Ultimate Classified Listings <= 1.4 Authenticated (Administrator+) Stored Cross-Site Scripting via Title Parameter
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ultimate Classified Listings plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Title parameter in all versions up to, and including, 1.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- webcodingplace Ultimate Classified Listings: before 1.5 — fixed in 1.5
How to fix
Upgrade to a fixed version: webcodingplace Ultimate Classified Listings 1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ultimate-classified-listings/tags/1.4/inc/helpers.php#L407
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2c925848-1ba7-4009-93c2-1648dbf808e9?source=cve
Get alerted when CVE-2024-13748 or the next vulnerability affects your stack