What’s Vulnerable › Vulnerabilities
CVE-2024-13749: StaffList <= 3.2.3 - Cross-Site Request Forgery to Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The StaffList plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.2.3. This is due to missing or incorrect nonce validation on the 'stafflist' page. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- era404 StaffList: before 3.2.4 — fixed in 3.2.4
How to fix
Upgrade to a fixed version: era404 StaffList 3.2.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3232922%40stafflist&new=3232922%40stafflist&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b8da640d-8965-45bb-be68-57d4eb598759?source=cve
Get alerted when CVE-2024-13749 or the next vulnerability affects your stack