What’s Vulnerable › Vulnerabilities
CVE-2024-13758: CP Contact Form with PayPal <= 1.3.52 - Cross-Site Request Forgery
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-352
Description
The CP Contact Form with PayPal plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.3.52. This is due to missing or incorrect nonce validation on the cp_contact_form_paypal_check_init_actions() function. This makes it possible for unauthenticated attackers to add discount codes via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- codepeople CP Contact Form with PayPal: before 1.3.53 — fixed in 1.3.53
How to fix
Upgrade to a fixed version: codepeople CP Contact Form with PayPal 1.3.53. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/cp-contact-form-with-paypal/trunk/cp_contactformpp_functions.php#L616
- https://plugins.trac.wordpress.org/changeset/3230873/
- https://wordpress.org/plugins/cp-contact-form-with-paypal/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/495183b6-dc7c-4ff7-bc99-fc05a10d1269?source=cve
Get alerted when CVE-2024-13758 or the next vulnerability affects your stack