What’s Vulnerable › Vulnerabilities
CVE-2024-1376: Event post <= 5.9.4 - Missing Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-24 · updated 2026-06-17
- Weakness: CWE-284
Description
The Event post plugin for WordPress is vulnerable to unauthorized bulk metadata update due to a missing capability check on the save_bulkdatas function in all versions up to, and including, 5.9.4. This makes it possible for authenticated attackers, with subscriber access or higher, to update post_meta_data.
Affected products
- Bastien Ho Event post: before 5.9.5 — fixed in 5.9.5
How to fix
Upgrade to a fixed version: Bastien Ho Event post 5.9.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3086840/event-post/trunk/eventpost.php?old=3060317&old_path=event-post%2Ftrunk%2Feventpost.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/926c09d5-3824-4745-99f6-50d9c945d252?source=cve
- https://plugins.trac.wordpress.org/changeset/3086840/event-post/trunk/eventpost.php?old=3060317&old_path=event-post%2Ftrunk%2Feventpost.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/926c09d5-3824-4745-99f6-50d9c945d252?source=cve
Get alerted when CVE-2024-1376 or the next vulnerability affects your stack