What’s Vulnerable › Vulnerabilities
CVE-2024-13769: Puzzles | WP Magazine / Review with Store WordPress Theme + RTL <= 4.2.4 - Missing Authorization to Authenticated (Subscriber+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-862
Description
The Puzzles | WP Magazine / Review with Store WordPress Theme + RTL theme for WordPress is vulnerable to Stored Cross-Site Scripting due to a missing capability check on the 'theme_options_ajax_post_action' AJAX action in all versions up to, and including, 4.2.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the plugin's settings and inject malicious web scripts. The developer opted to remove the software from the repository, so an update is not available and it is recommended to find a replacement software.
Affected products
- ThemeREX Puzzles | WP Magazine / Review with Store WordPress Theme + RTL: before 4.2.5 — fixed in 4.2.5
How to fix
Upgrade to a fixed version: ThemeREX Puzzles | WP Magazine / Review with Store WordPress Theme + RTL 4.2.5. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/puzzles-wordpress-magazinereview-with-wooc/5690583
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3c22d064-348d-4335-beaf-22dcdcf88518?source=cve
Get alerted when CVE-2024-13769 or the next vulnerability affects your stack