What’s Vulnerable › Vulnerabilities
CVE-2024-13774: Wishlist for WooCommerce: Multi Wishlists Per Customer <= 3.1.7 - Cross-Site Request Forgery to Cross-Site Scriping via Wishlist Name
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-08 · updated 2026-06-17
- Weakness: CWE-352
Description
The Wishlist for WooCommerce: Multi Wishlists Per Customer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.1.7. This is due to missing or incorrect nonce validation on the 'save_to_multiple_wishlist' function. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- WPFactory Wishlist for WooCommerce: before 3.1.8 — fixed in 3.1.8
How to fix
Upgrade to a fixed version: WPFactory Wishlist for WooCommerce 3.1.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wish-list-for-woocommerce/tags/3.1.7/includes/free/class-alg-wc-wish-list-ajax.php#L337
- https://plugins.trac.wordpress.org/browser/wish-list-for-woocommerce/tags/3.1.7/includes/free/class-alg-wc-wish-list-ajax.php#L789
- https://plugins.trac.wordpress.org/browser/wish-list-for-woocommerce/tags/3.1.8/includes/free/class-alg-wc-wish-list-ajax.php#L337
- https://plugins.trac.wordpress.org/browser/wish-list-for-woocommerce/tags/3.1.8/includes/free/class-alg-wc-wish-list-ajax.php#L789
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c11456bb-dde3-4ab8-b00b-a6cdcc68a760?source=cve
Get alerted when CVE-2024-13774 or the next vulnerability affects your stack