What’s Vulnerable › Vulnerabilities
CVE-2024-13775: WooCommerce Support Ticket System <= 17.8 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Post Deletion and Information Exposure
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-01 · updated 2026-06-17
- Weakness: CWE-862
Description
The WooCommerce Support Ticket System plugin for WordPress is vulnerable to unauthorized access and loss of data due to missing capability checks on the 'ajax_delete_message', 'ajax_get_customers_partial_list', and 'ajax_get_admins_list' functions in all versions up to, and including, 17.8. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary posts, and read names, emails, and capabilities of all users.
Affected products
- vanquish WooCommerce Support Ticket System: before 17.9 — fixed in 17.9
How to fix
Upgrade to a fixed version: vanquish WooCommerce Support Ticket System 17.9. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/woocommerce-support-ticket-system/17930050#item-description__change-log
- https://www.wordfence.com/threat-intel/vulnerabilities/id/72dc919a-c13d-49b4-927d-a0bb837b63dd?source=cve
Get alerted when CVE-2024-13775 or the next vulnerability affects your stack