What’s Vulnerable › Vulnerabilities
CVE-2024-13783: FormCraft <= 3.9.11 - Missing Authorization to Plugin Data Export in formcraft-main.php
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-862
Description
The FormCraft plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check in formcraft-main.php in all versions up to, and including, 3.9.11. This makes it possible for authenticated attackers, with Subscriber-level access and above, to export all plugin data which may contain sensitive information from form submissions.
Affected products
- nCrafts FormCraft: before 3.9.12 — fixed in 3.9.12
How to fix
Upgrade to a fixed version: nCrafts FormCraft 3.9.12. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/formcraft-premium-wordpress-form-builder/5335056
- https://formcraft-wp.com/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f7b45b1d-7ed6-4382-b69c-45ea45e4d0db?source=cve
Get alerted when CVE-2024-13783 or the next vulnerability affects your stack