What’s Vulnerable › Vulnerabilities
CVE-2024-13792: WooCommerce Food - Restaurant Menu & Food ordering <= 3.3.2 - Unauthenticated Arbitrary Shortcode Execution via ids
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-20 · updated 2026-06-17
- Weakness: CWE-94
Description
The WooCommerce Food - Restaurant Menu & Food ordering plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 3.3.2. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes.
Affected products
- Ex-Themes WooCommerce Food - Restaurant Menu & Food ordering: before 3.3.3 — fixed in 3.3.3
How to fix
Upgrade to a fixed version: Ex-Themes WooCommerce Food - Restaurant Menu & Food ordering 3.3.3. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/woocommerce-food-restaurant-menu-food-ordering/25457330
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ec425326-2729-4142-b5f4-460dfd3ed773?source=cve
Get alerted when CVE-2024-13792 or the next vulnerability affects your stack