What’s Vulnerable › Vulnerabilities
CVE-2024-13802: Bandsintown Events <= 1.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Bandsintown Events plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'bandsintown_events' shortcode in all versions up to, and including, 1.3.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- kwestion505 Bandsintown Events: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: kwestion505 Bandsintown Events 1.3.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/bandsintown/tags/1.3.1/bandsintown.php#L134
- https://plugins.trac.wordpress.org/changeset/3248689/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bab22f2e-0998-4401-ae9f-45bdce658c4f?source=cve
Get alerted when CVE-2024-13802 or the next vulnerability affects your stack