What’s Vulnerable › Vulnerabilities
CVE-2024-13805: Advanced File Manager <= 5.2.14 - Authenticated (Subscriber+) Stored Cross-Site Scripting via SVG File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced File Manager — Ultimate WordPress File Manager and Document Library Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 5.2.14 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, and granted permissions by an Administrator, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Affected products
- saadiqbal Advanced File Manager – Ultimate File Manager for WordPress And Document Library Solution: before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: saadiqbal Advanced File Manager – Ultimate File Manager for WordPress And Document Library Solution 5.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/file-manager-advanced/trunk/application/class_fma_connector.php
- https://plugins.trac.wordpress.org/changeset/3249482/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0fc6cc1b-7d49-48cd-9bce-d37c6dcfece9?source=cve
Get alerted when CVE-2024-13805 or the next vulnerability affects your stack