What’s Vulnerable › Vulnerabilities
CVE-2024-13808: Xpro Elementor Addons - Pro <= 1.4.9 - Authenticated (Contributor+) Remote Code Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-26 · updated 2026-06-17
- Weakness: CWE-94
Description
The Xpro Elementor Addons - Pro plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.4.9 via the custom PHP widget. This is due to their only being client side controls when determining who can access the widget. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server.
Affected products
- Xpro Addons — 140+ Widgets for Elementor: before 1.4.10 — fixed in 1.4.10
How to fix
Upgrade to a fixed version: Xpro Addons — 140+ Widgets for Elementor 1.4.10. Check the vendor advisory for mitigations.
References
- https://elementor.wpxpro.com
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0833e55f-22aa-44c9-aff6-1f3b74016e4c?source=cve
Get alerted when CVE-2024-13808 or the next vulnerability affects your stack