What’s Vulnerable › Vulnerabilities
CVE-2024-13814: Global Gallery - WordPress Responsive Gallery <= 9.1.5 - Authenticated (Subscriber+) Arbitrary Shortcode Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-94
Description
The The Global Gallery - WordPress Responsive Gallery plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 9.1.5. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes.
Affected products
- LCweb Global Gallery: before 9.1.6 — fixed in 9.1.6
How to fix
Upgrade to a fixed version: LCweb Global Gallery 9.1.6. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/global-gallery-wordpress-responsive-gallery/3310108
- https://lcweb.it/global-gallery-wordpress-photogallery-plugin/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4b5ba815-ce92-4d7b-aa80-29d6fddd7f63?source=cve
Get alerted when CVE-2024-13814 or the next vulnerability affects your stack