What’s Vulnerable › Vulnerabilities
CVE-2024-13821: WP Booking Calendar <= 10.10 - Unauthenticated Post-Confirmation Booking Manipulation
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-285
Description
The WP Booking Calendar plugin for WordPress is vulnerable to Unauthenticated Post-Confirmation Booking Manipulation in all versions up to, and including, 10.10. This is due to the plugin not properly requiring re-verification after a booking has been made and a change is being attempted. This makes it possible for unauthenticated attackers to manipulate their confirmed bookings, even after they have been approved.
Affected products
- WPdevelop/Oplugins Booking Calendar (WordPress plugin): before 10.10.1 — fixed in 10.10.1
How to fix
Upgrade to a fixed version: WPdevelop/Oplugins Booking Calendar (WordPress plugin) 10.10.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3234469%40booking&new=3234469%40booking&sfp_email=&sfph_mail=#file20
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8a0b961e-ccc3-4da0-b007-bbafa133a3a8?source=cve
Get alerted when CVE-2024-13821 or the next vulnerability affects your stack