What’s Vulnerable › Vulnerabilities
CVE-2024-13834: Responsive Plus – Starter Templates, Advanced Features and Customizer Settings for Responsive Theme <= 3.1.4 - Authenticated (Contributor+) Blind Server-Side Request Forgery via remote_request
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-15 · updated 2026-06-17
- Weakness: CWE-918
Description
The Responsive Plus – Starter Templates, Advanced Features and Customizer Settings for Responsive Theme plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 3.1.4 via the 'remote_request' function. This makes it possible for authenticated attackers, with contributor-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- cyberchimps Responsive Plus – Elementor Templates & Starter Sites: before 3.1.5 — fixed in 3.1.5
How to fix
Upgrade to a fixed version: cyberchimps Responsive Plus – Elementor Templates & Starter Sites 3.1.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3240422/responsive-add-ons
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b2833265-f1e5-4cfd-ad2f-ca28a59de82f?source=cve
Get alerted when CVE-2024-13834 or the next vulnerability affects your stack