What’s Vulnerable › Vulnerabilities
CVE-2024-13845: Gravity Forms WebHooks <= 1.6.0 - Authenticated (Admin+) Server-Side Request Forgery via Webhook
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-918
Description
The Gravity Forms WebHooks plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.6.0 via the 'process_feed' method of the GF_Webhooks class This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- Gravity Forms WebHooks: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Gravity Forms WebHooks 1.7.0. Check the vendor advisory for mitigations.
References
- https://www.gravityforms.com/blog/brand-new-release-webhooks-add-on-1-7/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9311b20b-daad-408f-a1a0-d1e42573ab97?source=cve
Get alerted when CVE-2024-13845 or the next vulnerability affects your stack