What’s Vulnerable › Vulnerabilities
CVE-2024-13846: Indeed Ultimate Learning Pro <= 3.9 - Authenticated (Administrator+) SQL Injection via post_id Parameter
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-21 · updated 2026-06-17
- Weakness: CWE-89
Description
The Indeed Ultimate Learning Pro plugin for WordPress is vulnerable to time-based SQL Injection via the ‘post_id’ parameter in all versions up to, and including, 3.9 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- azzaroco Ultimate Learning Pro: before 3.9.1 — fixed in 3.9.1
How to fix
Upgrade to a fixed version: azzaroco Ultimate Learning Pro 3.9.1. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/ultimate-learning-pro-wordpress-plugin/21772657
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e9ccd2cc-ee5e-40e3-905d-21884ec01f72?source=cve
Get alerted when CVE-2024-13846 or the next vulnerability affects your stack