What’s Vulnerable › Vulnerabilities
CVE-2024-13874: Feedify – Web Push Notifications < 2.4.6 - Reflected XSS
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Feedify WordPress plugin before 2.4.6 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- Feedify – Web Push Notifications: before 2.4.6 — fixed in 2.4.6
How to fix
Upgrade to a fixed version: Feedify – Web Push Notifications 2.4.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c808e7cf-3285-402b-ab4f-a40ab822b12e/
- https://wpscan.com/vulnerability/c808e7cf-3285-402b-ab4f-a40ab822b12e/
Get alerted when CVE-2024-13874 or the next vulnerability affects your stack