What’s Vulnerable › Vulnerabilities
CVE-2024-13903: quickjs-ng QuickJS qjs quickjs.c JS_GetRuntime stack-based overflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-21 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability was found in quickjs-ng QuickJS up to 0.8.0. It has been declared as problematic. Affected by this vulnerability is the function JS_GetRuntime of the file quickjs.c of the component qjs. The manipulation leads to stack-based buffer overflow. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The patch is named 99c02eb45170775a9a679c32b45dd4000ea67aff. It is recommended to upgrade the affected component.
Affected products
- quickjs-ng quickjs: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: quickjs-ng quickjs 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/quickjs-ng/quickjs/commit/99c02eb45170775a9a679c32b45dd4000ea67aff
- https://github.com/quickjs-ng/quickjs/issues/775
- https://github.com/quickjs-ng/quickjs/releases/tag/v0.9.0
- https://vuldb.com/?ctiid.300571
- https://vuldb.com/?id.300571
- https://vuldb.com/?submit.517394
Get alerted when CVE-2024-13903 or the next vulnerability affects your stack