What’s Vulnerable › Vulnerabilities
CVE-2024-13904: Platform.ly for WooCommerce <= 1.1.6 - Unauthenticated Blind Server-Side Request Forgery
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-07 · updated 2026-06-17
- Weakness: CWE-918
Description
The Platform.ly for WooCommerce plugin for WordPress is vulnerable to Blind Server-Side Request Forgery in all versions up to, and including, 1.1.6 via the 'hooks' function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- platformlycom Platform.ly for WooCommerce: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: platformlycom Platform.ly for WooCommerce 1.1.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/platformly-for-woocommerce/trunk/platformly-for-woocommerce.php#L167
- https://plugins.trac.wordpress.org/changeset/3249460
- https://www.wordfence.com/threat-intel/vulnerabilities/id/944e4c96-6ded-4483-9eaf-d976646f45ea?source=cve
Get alerted when CVE-2024-13904 or the next vulnerability affects your stack