What’s Vulnerable › Vulnerabilities
CVE-2024-13907: Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid <= 1.16.8 - Authenticated (Administrator+) Server-Side Request Forgery
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-918
Description
The Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.16.8 via the 'download' function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- boldgrid Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid: before 1.16.9 — fixed in 1.16.9
How to fix
Upgrade to a fixed version: boldgrid Total Upkeep – WordPress Backup Plugin plus Restore & Migrate by BoldGrid 1.16.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/boldgrid-backup/trunk/includes/class-boldgrid-backup-archive-fetcher.php#L141
- https://plugins.trac.wordpress.org/changeset/3246655/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/21da92d2-c38d-4a12-b850-bd0b580aaa54?source=cve
Get alerted when CVE-2024-13907 or the next vulnerability affects your stack