What’s Vulnerable › Vulnerabilities
CVE-2024-13910: Database Backup and check Tables Automated With Scheduler 2024 <= 2.36 - Authenticated (Administrator+) Arbitrary File Deletion
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-01 · updated 2026-06-17
- Weakness: CWE-22
Description
The Database Backup and check Tables Automated With Scheduler 2024 plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the 'database_backup_ajax_delete' function in all versions up to, and including, 2.35. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). The vulnerability was partially patched in version 2.36.
Affected products
References
- https://plugins.trac.wordpress.org/browser/database-backup/trunk/database-backup.php#L267
- https://plugins.trac.wordpress.org/changeset/3247917/
- https://plugins.trac.wordpress.org/changeset/3248708/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c92776c4-643c-40f2-ac28-5df5d6bf7fcd?source=cve
Get alerted when CVE-2024-13910 or the next vulnerability affects your stack