What’s Vulnerable › Vulnerabilities
CVE-2024-13918: Laravel Reflected XSS via Request Parameter in Debug-Mode Error Page
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.
Affected products
- Laravel Framework: from 11.9.0 before 11.36.0 — fixed in 11.36.0
How to fix
Upgrade to a fixed version: Laravel Framework 11.36.0. Check the vendor advisory for mitigations.
References
- https://github.com/laravel/framework/pull/53869
- https://github.com/laravel/framework/releases/tag/v11.36.0
- https://github.com/sbaresearch/advisories/tree/public/2024/SBA-ADV-20241209-01_Laravel_Reflected_XSS_via_Request_Parameter_in_Debug-Mode_Error_Page
- http://www.openwall.com/lists/oss-security/2025/03/10/3
Get alerted when CVE-2024-13918 or the next vulnerability affects your stack