What’s Vulnerable › Vulnerabilities
CVE-2024-13922: Order Export & Order Import for WooCommerce <= 2.6.0 - Directory Traversal to Authenticated (Administrator+) Limited Arbitrary File Deletion via admin_log_page Function
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-73
Description
The Order Export & Order Import for WooCommerce plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the admin_log_page() function in all versions up to, and including, 2.6.0. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete arbitrary log files on the server.
Affected products
- webtoffee Order Export & Order Import for WooCommerce: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: webtoffee Order Export & Order Import for WooCommerce 2.6.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/order-import-export-for-woocommerce/trunk/admin/modules/history/history.php#L248
- https://plugins.trac.wordpress.org/changeset/3258567/
- https://wordpress.org/plugins/product-import-export-for-woo/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4eb8f85f-656a-4e5a-a57d-7289da2cd951?source=cve
Get alerted when CVE-2024-13922 or the next vulnerability affects your stack