What’s Vulnerable › Vulnerabilities
CVE-2024-13923: Order Export & Order Import for WooCommerce <= 2.6.0 - Authenticated (Administrator+) Server-Side Request Forgery via validate_file Function
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-918
Description
The Order Export & Order Import for WooCommerce plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.6.0 via the validate_file() function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- webtoffee Order Export & Order Import for WooCommerce: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: webtoffee Order Export & Order Import for WooCommerce 2.6.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/order-import-export-for-woocommerce/trunk/admin/modules/import/classes/class-import-ajax.php#L175
- https://plugins.trac.wordpress.org/changeset/3258567/
- https://wordpress.org/plugins/order-import-export-for-woocommerce/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3283b3ff-1787-466b-9517-84bd715e4165?source=cve
Get alerted when CVE-2024-13923 or the next vulnerability affects your stack