What’s Vulnerable › Vulnerabilities
CVE-2024-13925: Klarna Checkout for WooCommerce < 2.13.5 - DoS via Excessive Logging
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-17 · updated 2026-06-17
Description
The Klarna Checkout for WooCommerce WordPress plugin before 2.13.5 exposes an unauthenticated WooCommerce Ajax endpoint that allows an attacker to flood the log files with data at the maximum size allowed for a POST parameter per request. This can result in rapid consumption of disk space, potentially filling the entire disk.
Affected products
- Klarna Checkout for WooCommerce: before 2.13.5 — fixed in 2.13.5
How to fix
Upgrade to a fixed version: Klarna Checkout for WooCommerce 2.13.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-13925 or the next vulnerability affects your stack