What’s Vulnerable › Vulnerabilities
CVE-2024-1399: Restaurant Menu and Food Ordering <= 2.4.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Restaurant Menu – Food Ordering System – Table Reservation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including, 2.4.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- gloriafood Restaurant Menu – Food Ordering System – Table Reservation: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: gloriafood Restaurant Menu – Food Ordering System – Table Reservation 2.4.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3064578%40menu-ordering-reservations%2Ftrunk&old=3022834%40menu-ordering-reservations%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4d419d9e-73c5-4d14-8da0-27a90924e0b5?source=cve
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3064578%40menu-ordering-reservations%2Ftrunk&old=3022834%40menu-ordering-reservations%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4d419d9e-73c5-4d14-8da0-27a90924e0b5?source=cve
Get alerted when CVE-2024-1399 or the next vulnerability affects your stack