What’s Vulnerable › Vulnerabilities
CVE-2024-14029: Tornado before 6.4.1 HTTP Request Smuggling via Transfer-Encoding
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-28
- Weakness: CWE-444
Description
Tornado before 6.4.1 ignores duplicate Transfer-Encoding: chunked headers, treating requests as having no message body and parsing the chunked body as a subsequent request. Attackers can exploit this inconsistency when Tornado is deployed behind proxies to perform HTTP request smuggling, enabling access control bypass, cache poisoning, or connection desynchronization.
Affected products
- Pypi Tornado: before 6.4.1; 0.2, 1.0, 1.1, 1.1.1, 1.2, 1.2.1 (+66) — fixed in 6.4.1
- tornadoweb tornado: before 6.4.1 — fixed in 6.4.1
How to fix
Upgrade to a fixed version: Pypi Tornado 6.4.1; tornadoweb tornado 6.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-753j-mpmx-qq6g
- https://www.vulncheck.com/advisories/tornado-before-6.4.1-http-request-smuggling-via-transfer-encoding
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-753j-mpmx-qq6g
Get alerted when CVE-2024-14029 or the next vulnerability affects your stack