What’s Vulnerable › Vulnerabilities

CVE-2024-14031: Sereal::Encoder versions from 4.000 through 4.009_002 for Perl embeds a vulnerable version of the Zstandard library

Description

Sereal::Encoder versions from 4.000 through 4.009_002 for Perl embeds a vulnerable version of the Zstandard library. Sereal::Encoder embeds a version of the Zstandard (zstd) library that is vulnerable to CVE-2019-11922. This is a race condition in the one-pass compression functions of Zstandard prior to version 1.3.8 could allow an attacker to write bytes out of bounds if an output buffer smaller than the recommended size was used.

Affected products

How to fix

Upgrade to a fixed version: YVES Sereal::Encoder 4.010. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-14031 or the next vulnerability affects your stack